Forum Replies Created

Viewing 15 reply threads
  • Author
    Posts
    • #53148
      Michael Cohen
      Participant

      @ Ambrose – Have your read the tech bulletin re the gasket on the coil pick up? Might that be your problem? I understand some people were having issues with limiting RPM’s due to this?

      Also we have have a few people at out track have the “Ring” wire connector crack and break that attaches to the ground on the head, as well as breaking on the one next to the battery…….

      Its also funny how many of the RED covers are missing on the starter switch’s as the seem to fly off.

       

    • #51568
      Michael Cohen
      Participant

      Bummer about failing in the heat race, but at least you had the spare parts to get going again. I really feel as if it must be in the harness’s plug…. I hope Rotax is aware of the problem….

    • #50051
      Michael Cohen
      Participant

      So my friends kid lost his as well. After the race he went looking around the track for it and found three of them….. Apparently they are snapped in and tend to fly off…..we put a drop of crazy glue on ours

    • #50050
      Michael Cohen
      Participant

      Last weekend at our track, we had a number of karts fail due to electrical problems. It really is a bummer to take all the time and efforts not to be able to race….. I would hope Rotax is at least listening and hopefully testing and retesting the wiring and connectors.

    • #48863
      Michael Cohen
      Participant

      Ok so this weekend we did NOT have loss of spark….. I’m convinced its in the wiring harness plug…..

      I loaded the plug with Dieletric grease, zip tied the plug and as Christian stated above I found out that the newer upgrade kit also included two rubber mounts for the coil and ECU…my kit only had one so I added one..now both my coil and ECU are rubber mounted.

      My concern is that the connection will fail again. As I’m hearing about this from more than one person, I’m hoping that Rotax upgrades the harness to have a better connector….

    • #48862
      Michael Cohen
      Participant

      Alex;

      We have had a number of people at our track with the same issue. See my post at http://ekartingnews.com/forums/topic/rotax-evo-parts-failing/

      It seems to be all in the plug connection…..

      Not fun at all. I did call MaxSpeed and they said they were not aware of any issues, furthermore although I purchased my EVO Upgrade through MaxSpeed and they told me to deal with my local dealer…..

       

    • #48713
      Michael Cohen
      Participant

      Hey Chris P;

      Sounds like we have the same issue….. Did you solve the problem? At this point I’m thinking it must be the wiring harness, likely something in the plug / connector to the ECU.  I’m going to try to find another one to swap out for this weekend…… Hoping that solves the issue.

    • #47702
      Michael Cohen
      Participant

      The plug / connector that the ECU plugs into. Even with zip ties holding it together there still was what looked like arching around the female connector holes…..

    • #47624
      Michael Cohen
      Participant

      Well after thinking we solved the problem, thinking the ECU failed…..it appears the its the connection. I had it zip tied so it would not vibrate etc…. but strange enough it started cutting out again after a full day of running great. I pushed a little on the wires that go into the connection and the motor rev’ed up? I’m not sure if I get another wiring harness or try to take apart the one I have and see if I can make the connections better. After removing the zip ties and unplugging it, I found what looked like arching around the connector holes……

    • #47242
      Michael Cohen
      Participant

      @ Eric; Did you solve the problem? Did you swap the ECU?

    • #47136
      Michael Cohen
      Participant

      Mark:

      As I was ordering parts yesterday the supplier told me he has seen a number of them fail…So I agree with you.  Its just strange to me that as a sealed unit it was intermittent..?

       

      Brett;

      At one point we were having a hard time getting over 12,500 RPM, then without much change it seemed to get better. I hate to assume anything with ROTAX, but after having the problem with it cutting out etc I assume it was the ECU as that seemed to make run way better.

       

      Scottie: Yes I do have it grounded to the head bolt, as well as another ground strap to the cases. I have heard this from others to use the head bolt so I am, I’m not sure why that would make a difference… Aren’t you grounding metal to metal why would the head bolt be different than a bolt on the cases?

      Thanks everyone for the input…..

       

      Michael

       

       

    • #43861
      Michael Cohen
      Participant

      I just updated some prices and added a set of RAIN wheels.

      Thanks

    • #43691
      Michael Cohen
      Participant

      Yes I have the hub and disk, I will be able to email photos tonight or tomorrow.

       

      Thanks

    • #43663
      Michael Cohen
      Participant

      Yes I know your looking for a VEN4 but could a VEN5 work for you?

      If so I have a Complete Rear Caliper V05 (with used red pads), Brake line and Master?

    • #43662
      Michael Cohen
      Participant

      When I read this post; although a really good question I had to laugh.

      We got into karting about 3 years ago. We learned really quickly that we needed to have spare parts…..lots of spare parts.

      The first year we needed more than we could have known as we were new and tended to get caught up in the mess in the back. So I learned fast how to replace bent parts etc…

      We have had coils fail, starters fail, found a float with a crack in it, a wiring harness was bad…radiator smashed, etc…etc……

      What made me laugh is just when I think I have enough spares I find that I need something that we don’t have. What’s been a help is we usually always pit with the same people, so between us one we should have the part(s).  But not always…..

      Good luck this year!!

    • #42817
      Michael Cohen
      Participant

      I have two

      1 CRG steering Wheel (has a nice cut / scrape on it), it would be ok if you wrapped it $70
      1 Aftermarket Steering Wheel (same size as the factory 2012+ CRG steering wheel, the 2012 CRG steering wheel is wider) $55

      Plus shipping from No Cal

Viewing 15 reply threads