Home Forums 2-Cycle Racing X-30 Won’t Key Start

Viewing 3 reply threads
  • Author
    Posts
    • #107719
      Bill Gerzabek
      Participant

      Any suggestions on trouble shooting starting X-30 with key. Did the following:

      New Battery, changed wiring harness, changed starter cable, changed key switch, changed power unit, changed starter relay, changed fuse. Checked grounds.

      Same problem with both engines. Turn key and nothing happens. Will start with external starter. Any hidden issues I am not thinking of. ?

      Thanks

       

       

      Bill Gerzabek
      bgerzabek@gmail.com

    • #107720
      tony zambos
      Participant

      Bill,
      have you tried to directly wire the starter to a battery? If you have the starter off the engine when you try this, be sure to secure the starter. It will try to jump off a workbench. Broken motor brushes used to be a problem with the old Leopard starters.
      I’ve also had battery chargers fail. A new, fully charged battery should read at least 12.5 volts.

      LAD Specialties customer / tony kart / rotax / kt100

    • #107724
      Bill Gerzabek
      Participant

      Thanks. Looks like a broken brush . Ordered a couple. Brush was broken where the silicone wasn’t.

      Bill Gerzabek
      bgerzabek@gmail.com

    • #107733
      tony zambos
      Participant

      Glad you found the problem

      LAD Specialties customer / tony kart / rotax / kt100

Viewing 3 reply threads
  • You must be logged in to reply to this topic.