Home Forums TaG Rotax Max Can't get more than 8000 RPM

Viewing 7 reply threads
  • Author
    Posts
    • #28873
      Mauricio Rivera
      Participant

      Got a Rotax 125 MAx. during one of my laps, motor started acting almost like it was running out of gas, pulled out and gas was fine. gave it a good check and went out again. Reaching around 8000 RPM it seems to act almost like the RPM limiter is kicking in. swapped carbs, resealed fuel pump, changed spark plug and checked power valve with no change. Going to check several other things but would like some input, talked to a local tech and said he had never heard a Rotax sound like that, sounds like it’s being limited somehow, maybe exhaust blockage?

      Thanks,

      Mauricio

    • #28882
      Steen Carstensen
      Participant

      My guess is your exhaust is broken. There is a perforated pipe inside the muffler part of the exhaust, and they break in half and thereby block the flow. You will need new one and also new packing.

    • #28904
      Mauricio Rivera
      Participant

      Thanks Steen, will checking that today.

    • #28905
      Mauricio Rivera
      Participant

      Could it possibly be the coil as well?

    • #28915
      tony zambos
      Participant

      Sure, it could be the coil, but work from the cheapest solution to the most expensive. You said you resealed the pump. Did you install a new pump kit? Any kinks in the fuel line, any tie-wraps restricting the fuel flow or a clogged fuel filter? Air filter clean? Any restrictions in the fuel tank, either pulling gas out of or a venting problem. Any cracks in the pump line? Have you tiried swapping batteries with some one? That would be the #1 item to replace. Have you checked on you ground?
      Not saying it wouldn’t be the coil and you if you have the opportunity to swap it out, go for it. But have a backup list of items to check if the coil doesn’t fix the problem. good luck

      LAD Specialties customer / tony kart / rotax / kt100

    • #28918
      Mauricio Rivera
      Participant

      Thanks for the input Tony, looks like it’s a broken exhaust stinger. Broken into three pieces and the packing collapsed and completely was blocking the exhaust. Temporarily re installed it to check of that was 100% the problem and now getting full RPM.  Thanks again for all your input.

    • #28922
      tony zambos
      Participant

      Good news.  Thanks for the update.

       

      LAD Specialties customer / tony kart / rotax / kt100

    • #28936
      Steen Carstensen
      Participant

      Glad you found the problem. Now buy 2 of each and keep the spares in your toolbox. :-))

Viewing 7 reply threads
  • You must be logged in to reply to this topic.