Forum Replies Created

Viewing 25 posts - 1 through 25 (of 30 total)
  • Author
    Posts
  • #72982

    Brian Spek
    Participant

    The winner may have won with a full grid anyway, but this must have put a damper on it for him too.  If 1 or 2 drivers were late to the grid due to their own fault, then cool.  But 10+ drivers getting caught out seems to be an event problem.  I feel bad for both the guys who got to race with 1/2 grid, and worse for the guys who did not.  Sucks for the sport. Makes one want to get an old Rotax again.:)

    • This reply was modified 1 month, 3 weeks ago by  Brian Spek.
    #63032

    Brian Spek
    Participant

    I’ve driven TAG with front brakes for 1 season (32mm Swiss) and then 2 seasons with rear-only brakes (Tony 32mm).  Front brakes had a 20 lb penalty, and was winning at AMP.  TS decided to ban fronts mid-season just before their big money race, didn’t bother to go.  Next season started with rear-only. Lap times were faster without the 20 lb penalty obviously, but we tested adding and removing weight with rears only, and was faster overall without rears.  Just need to get used to it.  Only downside is you change pads more often with rear-only.

    #58816

    Brian Spek
    Participant

    Thanks. Worked great.

    #55309

    Brian Spek
    Participant

    Check classic forums.  I posted info on a guy who can install a new battery.  Worked great.

    #53496

    Brian Spek
    Participant

    Robert,

    I have 3 used Rotax Pipe mounts that only attach to the engine side of the frame, which prevents the pipe from bending – in case your pipe attaches to both sides of the frame.  I’ve seen many welds around this spot due to this problem, not sure if Rotax legal or not.  If you want a mount, $50 plus shipping, they sell for $120.  We sold all our Rotax motors.

    Thanks

    Brian

    #52632

    Brian Spek
    Participant

    lawn mower battery, keep it on the battery tender, usually 14-18 months.  use it for 2 karts on race day, figure min 10 lifts and 10 drops for the day, plus load and unload on trailer, no problem with battery.

    #52589

    Brian Spek
    Participant

    had a similar issue.  first check to ensure a good spark.  throw in a new plug to be sure and get the plug grease to ensure a good fit with the boot and no arc’ing.  Then if that’s ok, go to the fuel system.  Mine started running again after rebuilding both fuel pumps, and replacing the pulse lines.  empty these after every race.  Also, if someone accidentally used the wrong oil, or a low oil-fuel ratio, it can cause problems.   if all else fails, check stator in case it was knocked out of synch.  also check all ignition connectors.

    #51813

    Brian Spek
    Participant

    short 1 lap video to show some of the cool elevation.

    https://www.youtube.com/watch?v=WPOFIm25u-c&feature=youtu.be

     

    #49192

    Brian Spek
    Participant

    We had a great 09 Rotax that would beat the X30’s, but our other 3 Rotax’s were around .6 sec slower on a .8mile track. We bought an X30 since more of them were appearing locally, pulled it out of the box and ran it with factory carb settings w/ no problem.  We read the plug and will make slight top end changes if it looks rich, but other than that, nothing.  So far on the X30 I am 25 hrs on bottom end and changed top end at 15 hrs. X30 will probably do 2 top ends and 1 full rebuild to get me to 50 hrs vs Rotax we would do 3 top ends to get to 50 hrs, so X30 will be more $ to maintain…but revving to 16000 is cool.  Not sure what the EVO upgrade will do for you if you get one.

    #45441

    Brian Spek
    Participant

    Thanks, it worked.  Now just have to figure out why the lap times don’t show on the screen.

    #34319

    Brian Spek
    Participant

    lots of good questions answered in the classic/old version of ekn as well:

    http://www.eknclassic.com

     

    #34208

    Brian Spek
    Participant

    ok so is there a trick to adding pictures to these forums?  Dustin, just text me your email address thanks.

    #34044

    Brian Spek
    Participant

    sure, can prep for shipping, but you arrange pickup/delivery.  uship.com is easy and has worked well for me in the past.

    #26672

    Brian Spek
    Participant

    you can try spraying sea foam into the carb while running the engine. $5 at auto zone.

    #25916

    Brian Spek
    Participant

    turn it on, and then try a hair dryer on it for a few minutes, some lasers won’t turn on when cool.

    #23233

    Brian Spek
    Participant

    valhalla 360 are good, stay away from donuts in my opinion.  have not tried a leatt.

    #21790

    Brian Spek
    Participant

    Any reason you cannot run it as-is in the TAG class there?

    #15430

    Brian Spek
    Participant

    .

    #14280

    Brian Spek
    Participant

    GA

    #13701

    Brian Spek
    Participant

    delete

    #12689

    Brian Spek
    Participant

    ..

    #8103

    Brian Spek
    Participant

    pls email # to brian.spek@gmail….  thanks.

    #7948

    Brian Spek
    Participant

    <div class=”d4p-bbp-quote-title”>Bub wrote:</div>
    Is the pipe new or old style? Do youhave a picture

    can send pics by email give me your email address pls.

    #7889

    Brian Spek
    Participant

    ——–pic sent

    #7729

    Brian Spek
    Participant

    <div class=”d4p-bbp-quote-title”>Ted Hamilton wrote:</div>
    yep

Viewing 25 posts - 1 through 25 (of 30 total)