Home Forums Tech Talk Tie rod rub

This topic contains 3 replies, has 4 voices, and was last updated by  Walt Gifford 2 weeks, 6 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #74156

    Snowbomb101
    Participant

    I am totally knew to karting so forgive me for my ignorance. I am building a ital kart rapido V shifter kart and noticed that the left tie rod rubs on the brake connecting rod between the brake lever and the master cylinder. I have the connecting rod in the highest position on both the lever and the master cylinder. It had to have been happening with the previous owner because the rubbing has worn off the paint on the tie rod.  The rubbing only occurs when steering to one side, I think to the right. Is this typical? It is really bothering me.  I am a perfectionist and want to fix this.

     

    thanks for your help in advance.

    #74157

    tony zambos
    Participant

    The rub is an ital kart feature. The rub will not be significant to impair steering or braking.

    LAD Specialties / tony kart / rotax / kt100

    #74197

    Matt Martin
    Participant

    I have an Intrepid Explorer (same chassis manufacturer) and run into the same issue.  Never felt any impact steering or braking while on the track.

    #74321

    Walt Gifford
    Participant

    Basically a problem on every kart. Usually the rub is out of the range of normal steering on track. Can you reconfigure the steering rod to a lower position?

    Gif

    FAA certified jet engine and aircraft technician,
    Nicholson Speedway class champion 2001,
    Yamaha KT100 Service Center,
    41 years karting experience

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Karting's News and Information Leader ekartingnews | an HMG publication