<!DOCTYPE html>
<html lang="en-US">
	<head>
        <meta charset="UTF-8" />
			<title>
			ROK Cup Promotions Sets 2018 ROK Cup USA Event Calendar &#8211; eKartingNews.com        </title>

        <link rel="profile" href="http://gmpg.org/xfn/11" />
    	<meta name='viewport' content='width=device-width, initial-scale=1, maximum-scale=1'>

        <!-- Google Fonts -->
        <link href='http://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700' rel='stylesheet' type='text/css'>
        <link href='http://fonts.googleapis.com/css?family=Questrial' rel='stylesheet' type='text/css'>
        <link href='http://fonts.googleapis.com/css?family=Bitter:400,700,400' rel='stylesheet' type='text/css'>
        <!-- Google Fonts -->

        <!-- Stylesheets -->
                <link rel="stylesheet" type="text/css" media="all" href="http://ekartingnews.com/wp-content/themes/ekartingtheme/styles/blue.css" />
        
        <link rel="stylesheet" type="text/css" media="all" href="http://ekartingnews.com/wp-content/themes/ekartingtheme/style.css" />
        <!-- <link rel="stylesheet" type="text/css" media="all" href="http://ekartingnews.com/wp-content/themes/ekartingtheme/colorbox/colorbox.css" /> -->

        
    
        <!-- Stylesheets -->

        <link rel="pingback" href="http://ekartingnews.com/xmlrpc.php" />

                    <link rel="shortcut icon" href="http://184.173.193.221/~ekarting/wp-content/uploads/2012/11/favicon.png" />
        
        <!-- jQuery Scripts and Plugins -->
        <script type="text/javascript" src="http://ekartingnews.com/wp-content/themes/ekartingtheme/js/jquery.js"></script>
        <script type="text/javascript" src="http://ekartingnews.com/wp-content/themes/ekartingtheme/js/jquery.masonry.min.js">
<script type="text/javascript" src="http://ekartingnews.com/wp-content/themes/ekartingtheme/js/jquery.imagesloaded.pkgd.js"></script>

<script type="text/javascript" src="http://ekartingnews.com/wp-content/themes/ekartingtheme/js/jquery.mobilemenu.js"></script>
<script type="text/javascript" src="http://ekartingnews.com/wp-content/themes/ekartingtheme/js/jquery.superfish.js"></script>
<script type="text/javascript" src="http://ekartingnews.com/wp-content/themes/ekartingtheme/js/custom.js"></script>
        
        <!-- <script type="text/javascript" src="http://ekartingnews.com/wp-content/themes/ekartingtheme/colorbox/jquery.colorbox-min.js"></script> -->
 
      
    <!-- Flex Slider -->
        <!-- Flex Slider CSS -->
        <link rel="stylesheet" href="http://ekartingnews.com/wp-content/themes/ekartingtheme/flex/flexslider.css" type="text/css" media="screen" />
        <!-- Flex Slider JS -->
        <script type="text/javascript" src="http://ekartingnews.com/wp-content/themes/ekartingtheme/flex/jquery.flexslider-min.js"></script>
        <script type="text/javascript">
            $(window).load(function() {
                $('.flexslider').flexslider({
                    slideshowSpeed: 5000,
                    animationDuration: 500                });
            });
		 </script>
        <!-- Flex Slider -->
                    
    
                
        <link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="eKartingNews.com &raquo; Feed" href="http://ekartingnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="eKartingNews.com &raquo; Comments Feed" href="http://ekartingnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="eKartingNews.com &raquo; ROK Cup Promotions Sets 2018 ROK Cup USA Event Calendar Comments Feed" href="http://ekartingnews.com/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/ekartingnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=88b46b47daab60bfffad905c937b617b"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bbpress_unread_posts_Style-css'  href='http://ekartingnews.com/wp-content/plugins/bbpress-unread-posts/style.css?ver=88b46b47daab60bfffad905c937b617b' type='text/css' media='all' />
<link rel='stylesheet' id='simple-payments-css'  href='http://ekartingnews.com/wp-content/plugins/jetpack/modules/simple-payments/simple-payments.css?ver=88b46b47daab60bfffad905c937b617b' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='gdbbx-render-css'  href='http://ekartingnews.com/wp-content/plugins/gd-bbpress-toolbox/css/render.min.css?ver=4.3.493' type='text/css' media='all' />
<link rel='stylesheet' id='gdbbx-widgets-css'  href='http://ekartingnews.com/wp-content/plugins/gd-bbpress-toolbox/css/widgets.min.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='bbp-default-css'  href='http://ekartingnews.com/wp-content/plugins/bbpress/templates/default/css/bbpress.css?ver=2.5.12-6148' type='text/css' media='screen' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='http://ekartingnews.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_icons-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-bootstrap-css'  href='http://ekartingnews.com/wp-content/themes/ekartingtheme/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css'  href='http://ekartingnews.com/wp-content/plugins/easy-table/themes/cuscosky/style.css?ver=1.6' type='text/css' media='all' />
<link rel='stylesheet' id='shiftnav-css'  href='http://ekartingnews.com/wp-content/plugins/shiftnav-pro/pro/assets/css/shiftnav.min.css?ver=1.4.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='shiftnav-font-awesome-css'  href='http://ekartingnews.com/wp-content/plugins/shiftnav-pro/assets/css/fontawesome/css/font-awesome.min.css?ver=1.4.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='shiftnav-slate-css'  href='http://ekartingnews.com/wp-content/plugins/shiftnav-pro/pro/assets/css/skins/slate.css?ver=1.4.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://ekartingnews.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=88b46b47daab60bfffad905c937b617b' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://ekartingnews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.2.1' type='text/css' media='all' />
<link rel='https://api.w.org/' href='http://ekartingnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ekartingnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ekartingnews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='PROgression: Team Benik Set for Watkins Glen USF2000 Event' href='http://ekartingnews.com/2017/08/30/progression-team-benik-set-for-watkins-glen-usf2000-event/' />
<link rel='next' title='Kid Karts Make Popular Return to WKA Manufacturers Cup Series at Dousman' href='http://ekartingnews.com/2017/08/30/kid-karts-make-popular-return-to-wka-manufacturers-cup-series-at-dousman/' />

<link rel="canonical" href="http://ekartingnews.com/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/" />
<link rel='shortlink' href='http://wp.me/p3KAp2-mcQ' />
<link rel="alternate" type="application/json+oembed" href="http://ekartingnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fekartingnews.com%2F2017%2F08%2F30%2Frok-cup-promotions-sets-2018-rok-cup-usa-event-calendar%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://ekartingnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fekartingnews.com%2F2017%2F08%2F30%2Frok-cup-promotions-sets-2018-rok-cup-usa-event-calendar%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.8.4 Professional to display their advertisements - http://www.adrotateplugin.com/ -->
<!-- AdRotate CSS for Blocks -->
<style type="text/css" media="screen">
.b-1 { overflow:auto;margin:0;padding:0px;clear:none;width:auto;height:auto; }
.a-1 { margin:0px;clear:none;float:left;width:150px;height:150px;border:0px #fff none; }
.b-2 { overflow:auto;margin:0;padding:0px;clear:none;width:auto;height:auto; }
.a-2 { margin:0px;clear:none;float:left;width:150px;height:605px;border:none; }
.b-3 { overflow:auto;margin:0;padding:0px;clear:none;width:auto;height:auto; }
.a-3 { margin:0px;clear:none;float:left;width:150px;height:150px;border:none; }
.b-4 { overflow:auto;margin:0;padding:0px;clear:none;width:auto;height:auto; }
.a-4 { margin:0px;clear:none;float:left;width:150px;height:150px;border:none; }
.b-7 { overflow:auto;margin:0;padding:0px;clear:none;width:auto;height:auto; }
.a-7 { margin:0px;clear:none;float:left;width:300px;height:100px;border:0px #fff none; }
.b-8 { overflow:auto;margin:0;padding:0px;clear:none;width:auto;height:auto; }
.a-8 { margin:0px;clear:none;float:left;width:140px;height:140px;border:0px #fff none; }
.block_left { clear:left; }
.block_right { clear:right; }
.block_both { clear:both; }
</style>
<!-- / AdRotate CSS for Blocks -->


<!-- Bad Behavior 2.2.19 run time: 2.466 ms -->
<script type="text/javascript">
<!--
function bb2_addLoadEvent(func) {
	var oldonload = window.onload;
	if (typeof window.onload != 'function') {
		window.onload = func;
	} else {
		window.onload = function() {
			oldonload();
			func();
		}
	}
}

bb2_addLoadEvent(function() {
	for ( i=0; i < document.forms.length; i++ ) {
		if (document.forms[i].method == 'post') {
			var myElement = document.createElement('input');
			myElement.setAttribute('type', 'hidden');
			myElement.name = 'bb2_screener_';
			myElement.value = '1504124595 54.224.77.253';
			document.forms[i].appendChild(myElement);
		}
	}
});
// --></script>
		<meta name="generator" content="GD bbPress Toolbox Pro 4.3, Build 493" />

	<script type="text/javascript">var ajaxurl = 'http://ekartingnews.com/wp-admin/admin-ajax.php';</script>


	<!-- ShiftNav CSS 
	================================================================ -->
	<style type="text/css" id="shiftnav-dynamic-css">
		
	@media only screen and (min-width:960px){ #shiftnav-toggle-main, .shiftnav-toggle-mobile{ display:none; } .shiftnav-wrap { padding-top:0 !important; } }
	@media only screen and (max-width:959px){ 960{ display:none !important; } }

/** ShiftNav Custom Menu Styles (Customizer) **/
/* togglebar */
#shiftnav-toggle-main { background:#1a1a1a; color:#ffffff; font-size:12px !important; }
#shiftnav-toggle-main.shiftnav-toggle-main-entire-bar:before, #shiftnav-toggle-main .shiftnav-toggle-burger { font-size:22px; }
/* shiftnav-main */
.shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu li.menu-item > .shiftnav-target { color:#ffffff; }
.shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu li.menu-item.shiftnav-active > .shiftnav-target, .shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu li.menu-item.shiftnav-in-transition > .shiftnav-target, .shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu.shiftnav-active-on-hover li.menu-item > .shiftnav-target:hover, .shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu.shiftnav-active-highlight li.menu-item > .shiftnav-target:active { background:#c9c9c9; color:#003399; }
.shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu li.menu-item.current-menu-item > .shiftnav-target, .shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu li.menu-item ul.sub-menu .current-menu-item > .shiftnav-target, .shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu > li.shiftnav-sub-accordion.current-menu-ancestor > .shiftnav-target, .shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu > li.shiftnav-sub-shift.current-menu-ancestor > .shiftnav-target { background:#8099cc; }
.shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu li.menu-item.shiftnav-highlight > .shiftnav-target, .shiftnav.shiftnav-shiftnav-main ul.shiftnav-menu li.menu-item ul.sub-menu .shiftnav-highlight > .shiftnav-target { background:#1a1a1a; color:#003399; }

/* Status: Loaded from Transient */

	</style>
	<!-- end ShiftNav CSS -->

	<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//ekartingnews.com/?wordfence_logHuman=1&hid=3F97123348326CB47ABDA389DEE3FADD');
</script>
<script type="text/javascript">
    /* <![CDATA[ */
    var gdbxRender_Data = { url: "http://ekartingnews.com/wp-admin/admin-ajax.php", run_quote: true, run_report: false, run_thanks: false, run_attachments: true, run_canned_replies: false, run_bbcodes: true, run_bbcodes_toolbar: false, run_signature: true, run_fitvids: true, wp_editor: true, wp_version: 48, sig_bbcodes: false, limiter: true, max_chars: 200, max_chars_warning: 180, last_cookie: 1504126396, bbpress_version: 25, text_are_you_sure: "Are you sure? Operation is not reversible.", now: 1504124596, validate_attachments: false, max_files: 4, max_size: 524288, allowed_extensions: "jpg jpeg jpe gif png bmp tiff tif ico asf asx wmv wmx wm avi divx flv mov qt mpeg mpg mpe mp4 m4v ogv webm mkv 3gp 3gpp 3g2 3gp2 txt asc c cc h srt csv tsv ics rtx css htm html vtt dfxp mp3 m4a m4b ra ram wav ogg oga mid midi wma wax mka rtf js pdf class tar zip gz gzip rar 7z psd xcf doc pot pps ppt wri xla xls xlt xlw mdb mpp docx docm dotx dotm xlsx xlsm xlsb xltx xltm xlam pptx pptm ppsx ppsm potx potm ppam sldx sldm onetoc onetoc2 onetmp onepkg oxps xps odt odp ods odg odc odb odf wp wpd key numbers pages", text_select_file: "Select File", text_file_name: "Name", text_file_size: "Size", text_file_type: "Extension", text_file_validation: "This file is not valid!", text_file_remove: "Remove this file", text_file_shortcode: "Insert into content", text_file_caption: "Set file caption", text_file_caption_placeholder: "Caption..." };
    /* ]]> */
</script>

        <script type="text/javascript" src="http://ekartingnews.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1504124596"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code_p { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="ROK Cup Promotions Sets 2018 ROK Cup USA Event Calendar" />
<meta property="og:url" content="http://ekartingnews.com/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/" />
<meta property="og:description" content="ROK Cup Promotions and ROK Cup USA are pleased to announce their much-anticipated 2018 calendar. With the karting landscape changing in North America, a careful approach was made to solidify 2018 r…" />
<meta property="article:published_time" content="2017-08-30T17:13:45+00:00" />
<meta property="article:modified_time" content="2017-08-30T17:33:04+00:00" />
<meta property="og:site_name" content="eKartingNews.com" />
<meta property="og:image" content="http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo.jpg" />
<meta property="og:image:width" content="620" />
<meta property="og:image:height" content="413" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
     </head>
    <body class="post-template-default single single-post postid-85364 single-format-standard">
        <div class="wrap">

            <!-- Login / Social Area -->
            <div id="social-login-bar">
                <!-- Social Icons -->
                                    <div class="left">
                        <div class="social_icons">
                                                            <a href="https://www.facebook.com/eKartingNews" class="facebook"></a>
                                                                                        <a href="https://twitter.com/ekartingnews" class="twitter"></a>
                                                                                        <a href="https://itunes.apple.com/us/podcast/ekartingnews.com-trackside/id493365237" class="itunes"></a>
                                                                                                                    <a href="http://www.ekartingnews.com/live" class="eknlive"></a>
                                                                                        <a href="http://www.youtube.com/user/ekartingnewsvideo" class="youtube"></a>
                                                                                                                    <a href="http://www.instagram.com/ekartingnews" class="instagram"></a>
                                                                                </div>
                    </div>
                
                                <div id="ekn-login" class="right">
                    <a href="http://ekartingnews.com/login">Login</a> | <a href="http://ekartingnews.com/wp-login.php?action=register">Register</a>
                </div>
                
                <!-- CLEAR -->
                <div class="clear"></div>
            </div>

            <div id="header">
            
            <!-- HEADER -->

                <!-- LOGO -->
                                    <a id="logo" href="http://ekartingnews.com" title="eKartingNews.com">eKartingNews.com</a>
                                <!-- TOP AD - 375 x 60 -->
                <div id="logo-ad" class="right">
                    <a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=NTAsMCwwLGh0dHA6Ly93d3cuZWthcnRpbmduZXdzLmNvbS9zdG9yZQ=" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/Platinum-EKN Gear.jpg" /></a>                </div>

                <!-- CLEAR -->
                <div class="clear"></div>
            </div>

            <div id="navigation"><!-- NAVIGATION -->
                <div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-894" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-894"><a href="http://ekartingnews.com/">Home</a></li>
<li id="menu-item-896" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-896"><a href="http://ekartingnews.com/news/">Headlines</a>
<ul  class="sub-menu">
	<li id="menu-item-915" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-915"><a href="http://ekartingnews.com/category/top-stories/">Top Stories</a></li>
	<li id="menu-item-913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-913"><a href="http://ekartingnews.com/category/news/">News</a></li>
	<li id="menu-item-912" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-912"><a href="http://ekartingnews.com/category/international/">International</a></li>
	<li id="menu-item-76462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76462"><a href="http://ekartingnews.com/category/newswire/">Newswire</a></li>
	<li id="menu-item-914" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-914"><a href="http://ekartingnews.com/category/pr-wire/">PR Wire</a></li>
	<li id="menu-item-5236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5236"><a href="http://ekartingnews.com/category/ekn-event-pages/">EKN Event Pages</a></li>
	<li id="menu-item-15254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15254"><a href="http://ekartingnews.com/category/paddock-insider/">Paddock Insider</a></li>
	<li id="menu-item-33136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33136"><a href="http://ekartingnews.com/category/canada/">Canada</a></li>
</ul>
</li>
<li id="menu-item-905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-905"><a href="http://ekartingnews.com/category/features/">Features</a>
<ul  class="sub-menu">
	<li id="menu-item-40870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40870"><a href="http://ekartingnews.com/category/chassis-showroom/">EKN Chassis Showroom</a></li>
	<li id="menu-item-908" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-908"><a href="http://ekartingnews.com/category/constructors-championship/">Constructors Championship</a></li>
	<li id="menu-item-909" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-909"><a href="http://ekartingnews.com/category/driver-of-the-month/">Driver Of The Month</a></li>
	<li id="menu-item-40376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40376"><a href="http://ekartingnews.com/category/driver-diary/">EKN Driver Diary</a></li>
	<li id="menu-item-910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-910"><a href="http://ekartingnews.com/category/driver-rankings/">Driver Rankings</a></li>
	<li id="menu-item-55572" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55572"><a href="http://ekartingnews.com/category/industry-insider/">Industry Insider</a></li>
	<li id="menu-item-18814" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18814"><a href="http://ekartingnews.com/category/1on1/">EKN One-on-One</a></li>
	<li id="menu-item-38700" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38700"><a href="http://ekartingnews.com/category/ontrack/">EKN OnTrack</a></li>
	<li id="menu-item-20717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20717"><a href="http://ekartingnews.com/category/grassroots/">Operation Grassroots</a></li>
	<li id="menu-item-59332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59332"><a href="http://ekartingnews.com/category/product/">Product Spotlight</a></li>
	<li id="menu-item-41221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41221"><a href="http://ekartingnews.com/category/road-racing/">Road Racing</a></li>
	<li id="menu-item-66913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66913"><a href="http://ekartingnews.com/category/vintage/">Vintage</a></li>
	<li id="menu-item-911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-911"><a href="http://ekartingnews.com/category/ekn-101/">EKN 101</a></li>
</ul>
</li>
<li id="menu-item-902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-902"><a href="http://ekartingnews.com/category/columns/">Columns</a>
<ul  class="sub-menu">
	<li id="menu-item-13620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13620"><a href="http://ekartingnews.com/category/columns/rob-howden/">Rob Howden</a></li>
	<li id="menu-item-13618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13618"><a href="http://ekartingnews.com/category/columns/david-cole/">David Cole</a></li>
	<li id="menu-item-13619" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13619"><a href="http://ekartingnews.com/category/columns/guest-columns/">Guest Columns</a></li>
	<li id="menu-item-13606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13606"><a href="http://ekartingnews.com/category/columns/morning-coffee/">Morning Coffee</a></li>
	<li id="menu-item-25805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25805"><a href="http://ekartingnews.com/category/columns/from-the-tower/">From the Tower</a></li>
</ul>
</li>
<li id="menu-item-907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-907"><a href="http://ekartingnews.com/forums">Forums</a>
<ul  class="sub-menu">
	<li id="menu-item-4598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4598"><a href="http://ekartingnews.com/forums">Forums</a></li>
	<li id="menu-item-78098" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-78098"><a href="http://ekartingnews.com/forums/forum/kart-mall/">EKN Kart Mall</a></li>
	<li id="menu-item-3501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3501"><a href="http://ekartingnews.com/faq/">Forum Guidelines &#8211; FAQ</a></li>
	<li id="menu-item-10494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10494"><a href="http://ekartingnews.com/forums/view/latest-topics/">New Topics</a></li>
	<li id="menu-item-14619" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14619"><a href="http://ekartingnews.com/forums/view/new-posts-last-visits/">New Posts Since Last Visit</a></li>
	<li id="menu-item-10319" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10319"><a href="http://ekartingnews.com/members">EKN Global Members</a></li>
	<li id="menu-item-4600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4600"><a href="http://eknclassic.com/forum.php">EKN Classic Forum Archive</a></li>
</ul>
</li>
<li id="menu-item-33172" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33172"><a href="http://www.ekartingnews.com">Media</a>
<ul  class="sub-menu">
	<li id="menu-item-80809" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80809"><a href="http://ekartingnews.com/podcast/">Podcast</a></li>
	<li id="menu-item-33173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33173"><a href="http://ekartingnews.com/category/video/">Video</a></li>
	<li id="menu-item-33174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33174"><a href="https://www.youtube.com/user/ekartingnewsvideo/">EKN Youtube</a></li>
	<li id="menu-item-60594" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60594"><a href="http://ekartingnews.com/galleries/">Photo Galleries</a></li>
</ul>
</li>
<li id="menu-item-5469" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5469"><a href="http://www.ekartingnews.com/live">Live</a></li>
<li id="menu-item-16096" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16096"><a href="http://styledaesthetic.com/ekartingnews/">e &#8211; SWAG</a></li>
<li id="menu-item-36082" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36082"><a href="http://www.ekartingnews.com">Series/Events</a>
<ul  class="sub-menu">
	<li id="menu-item-3485" class="ekn-canada menu-item menu-item-type-custom menu-item-object-custom menu-item-3485"><a href="http://ekartingnews.com/category/canada/">EKN CANADA</a></li>
	<li id="menu-item-45508" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45508"><a href="http://ekartingnews.com/category/briggs/">Briggs Racing</a></li>
	<li id="menu-item-36072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36072"><a href="http://ekartingnews.com/category/can-am/">Can-Am Karting Challenge</a></li>
	<li id="menu-item-36076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36076"><a href="http://ekartingnews.com/category/challenge-of-the-americas/">Challenge Of The Americas</a></li>
	<li id="menu-item-36073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36073"><a href="http://ekartingnews.com/category/florida-winter-tour/">Florida Winter Tour</a></li>
	<li id="menu-item-60676" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60676"><a href="http://ekartingnews.com/category/ikf/">International Kart Federation</a></li>
	<li id="menu-item-81282" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81282"><a href="http://ekartingnews.com/category/lakc/">Los Angeles Karting Championship</a></li>
	<li id="menu-item-36074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36074"><a href="http://ekartingnews.com/category/rigp/">Rock Island Grand Prix</a></li>
	<li id="menu-item-36075" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-36075"><a href="http://ekartingnews.com/category/rok-cup-usa/">Rok Cup USA</a></li>
	<li id="menu-item-79684" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79684"><a href="http://ekartingnews.com/category/route-66/">Route 66 Sprint Series</a></li>
	<li id="menu-item-36077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36077"><a href="http://ekartingnews.com/category/superkarts-usa/">Superkarts! USA</a></li>
	<li id="menu-item-36078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36078"><a href="http://ekartingnews.com/category/texas-pkc/">Texas ProKart Challenge</a></li>
	<li id="menu-item-36079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36079"><a href="http://ekartingnews.com/category/uspks/">United States Pro Kart Series</a></li>
	<li id="menu-item-36080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36080"><a href="http://ekartingnews.com/category/usrmc/">United States Rotax Max Challenge</a></li>
	<li id="menu-item-40834" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40834"><a href="http://ekartingnews.com/category/world-karting-association/">World Karting Association</a></li>
</ul>
</li>
</ul></div>
                <div class="submenu-container"><ul id="menu-sub-menu" class="menu"><li id="menu-item-80810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80810"><a href="http://ekartingnews.com/podcast/">Podcast</a></li>
<li id="menu-item-74856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74856"><a href="http://ekartingnews.com/category/world-karting-association/">World Karting Association</a></li>
<li id="menu-item-79923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79923"><a href="http://ekartingnews.com/category/uspks/">United States Pro Kart Series</a></li>
<li id="menu-item-85047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85047"><a href="http://ekartingnews.com/category/rigp/">Rock Island Grand Prix</a></li>
</ul></div>
                <!-- CLEAR -->
                <div class="clear"></div>

            </div>

            <!-- Leaderboard Ad -->
            <div id="leaderboard-ad">

                <!-- TOP AD - 728 x 90 -->
                <div class="left top_ad_area">
                    <a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=Mjk3LDEsMCxodHRwOi8vcm91dGU2NmthcnRyYWNpbmcuY29tLw=" target="_blank"><img src="http://ekartingnews.com/wp-content/uploads/2017/08/LB-USPKS-2017-0830.gif" /></a>                </div>

                <div class="clear"></div>
            </div>	
	
<div id="slider_wrap">
	</div>
	
	<div id="main_content"><!-- MAIN CONTENT AREA -->
		<div id="content_area"><!-- CONTENT AREA -->
							<div class="st-block"><!-- EKN BLOCK -->
					<div class="st-block-content"><!-- block content -->
                                            <div class="st-block-heading-wrapper">
						<h2 class="st-block-heading-single">ROK Cup Promotions Sets 2018 ROK Cup USA Event Calendar</h2><!-- heading -->
                                                
                                                <!-- Sub Headlines -->
                                                <h3 class="ekn-subheading">Florida Winter Tour, ROK Festival and ROK the RIO highlight 2018</h3>                                            </div>
						
						                                                
                                                        <!--
							<div class="st-block-misc">
								<div class="date">
									<div class="day">30</div>
									<div class="month">August</div>
									<div class="year">2017</div>
								</div>
								
								<div class="post_misc">
									<p>Written by PR Wire</p>
									<p><a href="http://ekartingnews.com/category/ekn-lead-story/" rel="category tag">EKN Lead Story</a> / <a href="http://ekartingnews.com/category/rok-cup-usa/" rel="category tag">Rok Cup USA</a> / <a href="http://ekartingnews.com/category/top-stories/" rel="category tag">Top Stories</a></p>
								</div>
								
								<div class="comments">
									<span>0</span> Comments								</div>
                                                       -->
								
							<div class="st-block-misc">
								<div class="byline">
									August 30, 2017 by <b>PR Wire</b>
								</div>
                                                            
                                                                <div class="byline-cat">
									<a href="http://ekartingnews.com/category/ekn-lead-story/" rel="category tag">EKN Lead Story</a> / <a href="http://ekartingnews.com/category/rok-cup-usa/" rel="category tag">Rok Cup USA</a> / <a href="http://ekartingnews.com/category/top-stories/" rel="category tag">Top Stories</a>								</div>
                                                            <div class="clear"></div>
							</div>
													<div class="sharedaddy"></div>
							<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this story:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-85364" class="share-facebook sd-button share-icon" href="http://ekartingnews.com/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-85364" class="share-twitter sd-button share-icon" href="http://ekartingnews.com/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://ekartingnews.com/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-85364" class="share-google-plus-1 sd-button share-icon" href="http://ekartingnews.com/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-85364" class="share-pinterest sd-button share-icon" href="http://ekartingnews.com/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://ekartingnews.com/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>    					<div class="st-block-full-content">
															<div class="post_thumbnail_full"> 
                                                                    <a href="http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo.jpg" title="ROK Cup Promotions Sets 2018 ROK Cup USA Event Calendar" ><img width="620" height="413" src="http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo.jpg 620w, http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo-300x199.jpg 300w, http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo-148x98.jpg 148w, http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo-31x20.jpg 31w, http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo-38x25.jpg 38w, http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo-322x215.jpg 322w, http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo-150x99.jpg 150w, http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo-500x333.jpg 500w" sizes="(max-width: 620px) 100vw, 620px" data-attachment-id="2107" data-permalink="http://ekartingnews.com/2013/03/22/series-news-rok-cup-usa-tech-updates-for-immediate-implementation/rok-cup-usa-logo/" data-orig-file="http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo.jpg" data-orig-size="620,413" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="Rok Cup USA logo" data-image-description="" data-medium-file="http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo-300x199.jpg" data-large-file="http://ekartingnews.com/wp-content/uploads/2013/03/Rok-Cup-USA-logo.jpg" /></a>                                                                                                                                    </div>
														
							<p>ROK Cup Promotions and ROK Cup USA are pleased to announce their much-anticipated 2018 calendar. With the karting landscape changing in North America, a careful approach was made to solidify 2018 race dates that would not only be good for teams and drivers, but also good for the sport of karting in the United States.</p>
<p>“Make no bones about it, the 2017 schedule was tough for the racers and teams and I understand that it needed a face lift for 2018. We have put a lot of time and thought into next year’s program,” explains Garett Potter, ROK Cup USA Director of Operations. “I think everyone will like what we have planned. On a much more positive note, we estimate we will have close to 600 new Vortex ROK engines in five new markets by the end of the year. With this huge investment and solid partners that jumped on board this year, it is clear ROK is here to stay.”</p>
<p>“The one question I have received by almost every person that I talked to is, ‘Are we going to Vegas?’” continues Potter. “I’m happy to say yes, after months of negotiation, we have signed a long term agreement with Caesars Entertainment. So pack your bags, and bring your Halloween costume because this is one you can’t miss! We will have some big news about this weekend in the future.”</p>
<p><strong>ROK Florida Winter Tour</strong><br />
To start off the 2018 season, ROK Cup USA will begin at the 20th annual Florida Winter Tour with the traditional three-event format during the first three months of the year. With ROK International Finals tickets available to the champions of Vortex Mini ROK, Junior ROK, Senior ROK, Masters ROK, Shifter ROK, and Shifter Masters ROK, ROK Cup USA will pick up where previous promoters have left off, leaving the historic FWT program in place, forgoing the double weekend as in years past and moving to a one weekend only event. The Vortex Micro ROK champion as well as second and third place championship finishers in all ROK classes will receive a ROK the RIO prize package that includes a free entry to the much-anticipated Vegas program. The traditional qualifying, three heat race, prefinal, final format will remain intact over the three official event days each and every weekend with more details to be announced in the future.</p>
<p>The 2018 Florida Winter Tour, the first with ROK Cup USA as promoter, will begin January 18-21 at the Palm Beach Karting facility in Jupiter, Florida before tracking north to Ocala Gran Prix during the February 15-18 weekend. Both of these facilities are familiar with the Florida Winter Tour program and participants, and always provide for some great racing action. Series champions will be crowned at the March 15-18 round at Orlando Kart Center in Orlando, Florida, another returning track to the series, and a favorite among many karters.</p>
<p>Potter adds, “We are looking forward to this year’s FWT, heading back to some of the best tracks in the state, keeping a long history in the karting industry going and with Challenge of the Americas on the West Coast, the first three months of 2018 are going to be ‘ROKKEN!’”</p>
<p><strong>ROK Festival</strong><br />
Something new for 2018 will be the ROK Festival. These one-off event weekends will not only have big prizes but a renewed effort to bring the word ‘FUN’ back into karting. The first of the ROK Festivals will take place May 17-20 at the multi-circuit NOLA Motorsports Park facility just outside New Orleans, Louisiana, one of the best facilities in the country and undoubtedly a racer favorite.</p>
<p>The second and final event of the ROK Festival program will take place at Oakland Valley Race Park (OVRP) in Cuddebackville, New York, located in the Northeast and close to ROK Cup Canada distributor Goodwood Kartways.</p>
<p>“Everyone that made the trip last year had a great time,” comments Potter. “Tim (Hannen) and his crew are amazing to work with and pull out all the stops to make sure we all have a good time. This event could be the largest ROK event out of the borders of Florida with a large international crowd expected to compete in the newly resurfaced facility over the July 19-22 weekend.”</p>
<p>Each event will see a unique trophy theme with the full podium receiving ROK the RIO tickets. Winners of the OVRP ROK Festival will not only obtain ROK the RIO tickets but also International Final tickets to join Team USA in South Garda, Italy as long as they participated in both Festivals.</p>
<p><strong>ROK the RIO</strong><br />
The final event on the 2018 ROK Cup USA calendar will be the first annual ROK the RIO at the Rio All-Suites Hotel &amp; Casino in Las Vegas, Nevada. Taking place October 30-November 3, 2018, the premiere event will award cash and prizes to each and every Vortex ROK division including $2500 to first, $1000 for second, $750 for third, $500 for fourth and $250 for fifth in Vortex Micro ROK, Mini ROK, Junior ROK, Senior ROK, Masters ROK, Shifter ROK and Shifter Masters ROK, making a total cash purse of almost $35,000.</p>
<p>“Vegas here we come,” concludes Potter. “With interest from around the world, and big names and partners already locked in, this will be a must-attend event. We understand it will take a some years to make this a world spectacle, but with the long-term commitment from Caesars Entertainment, Vortex and Bridgestone, the path is set!”</p>
<p>Now, with a fresh slate, renewed focus and energy, and a solid management team in place, ROK Cup USA is ready to grow the Vortex ROK brand in 2018 and beyond.</p>
<p><u>Complete 2018 ROK Cup USA race calendar: </u><br />
<strong>Florida Winter Tour</strong><br />
January 18-21 &#8211; Palm Beach Karting &#8211; Jupiter, Florida<br />
February 15-18 &#8211; Ocala Gran Prix &#8211; Ocala, Florida<br />
March 15-18 &#8211; Orlando Kart Center &#8211; Orlando, Florida</p>
<p><strong>ROK Festival </strong><br />
NOLA ROK Festival &#8211; May 17-20 &#8211; NOLA Motorsports Park &#8211; Avondale, Louisiana<br />
OVRP ROK Festival &#8211; July 19-22 &#8211; Oakland Valley Race Park &#8211; Cuddebackville, New York</p>
<p><strong>ROK the RIO </strong><br />
October 30-November 3 &#8211; Rio All Suites Hotel &amp; Casino &#8211; Las Vegas, Nevada</p>
<p>Please stay tuned for more details on the 2018 Vortex ROK, local and regional racing programs covering North America.</p>
<p>For more information on ROK Cup USA and ROK Cup Promotions, please feel free to contact ROK CUP USA at (407) 476-5635 or <a href="mailto:info@rokcupusa.com" target="_blank" rel="noopener">info@rokcupusa.com</a> or Garett Potter at <a href="mailto:garett@rokcupusa.com" target="_blank" rel="noopener">garett@rokcupusa.com</a></p>
							
							<p class="tags"></p>
							
							<div class="clear"></div>
						</div>
						
														<div id="comments">
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">EKN Global Members Discussion: <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/08/30/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://ekartingnews.com/wp-login.php?redirect_to=http%3A%2F%2Fekartingnews.com%2F2017%2F08%2F30%2Frok-cup-promotions-sets-2018-rok-cup-usa-event-calendar%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments -->
												
						<!-- CLEAR -->
						<div class="clear"></div>
					</div>
				</div>
					</div>
		
		<div id="sidebar"><!-- SIDEBAR -->
			<div class="st-block"><div class="st-block-content"><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MjIwLDUsMCxodHRwOi8vaHBkLmhvbmRhLmNvbS9rYXJ0aW5nLw=" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/MR-Honda-HPD-2016-1130.gif" /></a></div></div><div class="st-block"><div class="st-block-content"><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MjM2LDksMCxodHRwOi8vd3d3Lm1hcmdheS5jb20vcmFjZS13aXRoLXVzL2lnbml0ZS1zaG9vdG91dC5odG1s" target="_blank"><img src="http://ekartingnews.com/wp-content/uploads/2017/07/BB-Margay-2017-0712.gif" /></a></div></div><div class="st-block"><div class="st-block-content"><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MjgwLDEwLDAsaHR0cHM6Ly93d3cuZmFjZWJvb2suY29tL1RyaW5pdHktS2FydGluZy1Hcm91cC1JbmMtMzE4ODA2MjU4MzEyOTY1Lw=" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/FB-Trinity-2017-0301.gif" /></a></div></div><div class="st-block"><div class="st-block-content"><div id="b-3" class="block_outer b-3"><div id="a-216" class="block_inner a-3 block_left "><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MjE2LDAsMyxodHRwOi8vaWFtZXVzYWVhc3QuY29tLw=" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/DB-IAME USA East-2014-1117.jpg" /></a></div><div id="a-259" class="block_inner a-3 block_right "><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MjU5LDAsMyxodHRwOi8vd3d3Lnplcm8tZXJyb3IuY29tLw=" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/DB-ZeroError-2016-0303.gif" /></a></div></div></div></div><div class="st-block"><div class="st-block-content"><h2 class="st-block-heading"><span>EKN Editorial Search</span></h2><form role="search" method="get" id="searchform" action="http://ekartingnews.com/">
	<input type="text" value="To search type and hit enter" onblur="if(this.value == '') this.value = 'To search type and hit enter'" onfocus="if(this.value == 'To search type and hit enter') this.value = ''" name="s" id="s" />
	<input type="submit" id="searchsubmit" value="Search" />
</form></div></div><div class="st-block"><div class="st-block-content"><div id="b-3" class="block_outer b-3"><div id="a-49" class="block_inner a-3 block_left "><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=NDksMCwzLGh0dHA6Ly93d3cua2FydGxpZnQuY29t" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/DB-KartLift-2014-0129.gif" /></a></div><div id="a-224" class="block_inner a-3 block_right "><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MjI0LDAsMyxodHRwOi8vd3d3LnRpbGxldHRzZWF0cy5jb20vZXN0b3JlLw=" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/DB-TillettUSA-2015-0430.gif" /></a></div></div></div></div><div class="st-block"><div class="st-block-content"><div id="b-3" class="block_outer b-3"><div id="a-6" class="block_inner a-3 block_left "><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=NiwwLDMsaHR0cDovL3d3dy4zZ2thcnRyYWNpbmcuY29t" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/DB-3G-2015-0311.gif" /></a></div><div id="a-207" class="block_inner a-3 block_right "><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MjA3LDAsMyxodHRwOi8vY2FtYnJpYW5nb2thcnRzLmNvbS9zdG9yZS8" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/DB-Cambrian-2016-1214.gif" /></a></div></div></div></div><div class="st-block"><div class="st-block-content"><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MjMzLDEyLDAsaHR0cDovL3d3dy5kcmVhbXNjYXB0dXJlZHBob3RvLm5ldC8" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/FB-DreamsCaptured-2015-0717.jpg" /></a></div></div><div class="st-block"><div class="st-block-content"><div id="b-3" class="block_outer b-3"><div id="a-119" class="block_inner a-3 block_left "><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MTE5LDAsMyxodHRwOi8vd3d3LmhycHJhY2luZy5jb20va2FydGluZy0y" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/DB-Streeter-2016-0127.jpg" /></a></div><div id="a-258" class="block_inner a-3 block_right "><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MjU4LDAsMyxodHRwOi8vd3d3LnNob3AuZXNoaWZ0ZXJrYXJ0LmNvbS8" target="_blank"><img src="http://ekartingnews.com/wp-content/banners/DB-eshifterkart-2016-1010.gif" /></a></div></div></div></div><div class="st-block"><div class="st-block-content"><h2 class="st-block-heading"><span>EKN Editorial Directory</span></h2><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-894"><a href="http://ekartingnews.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-896"><a href="http://ekartingnews.com/news/">Headlines</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-915"><a href="http://ekartingnews.com/category/top-stories/">Top Stories</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-913"><a href="http://ekartingnews.com/category/news/">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-912"><a href="http://ekartingnews.com/category/international/">International</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76462"><a href="http://ekartingnews.com/category/newswire/">Newswire</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-914"><a href="http://ekartingnews.com/category/pr-wire/">PR Wire</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5236"><a href="http://ekartingnews.com/category/ekn-event-pages/">EKN Event Pages</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15254"><a href="http://ekartingnews.com/category/paddock-insider/">Paddock Insider</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33136"><a href="http://ekartingnews.com/category/canada/">Canada</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-905"><a href="http://ekartingnews.com/category/features/">Features</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40870"><a href="http://ekartingnews.com/category/chassis-showroom/">EKN Chassis Showroom</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-908"><a href="http://ekartingnews.com/category/constructors-championship/">Constructors Championship</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-909"><a href="http://ekartingnews.com/category/driver-of-the-month/">Driver Of The Month</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40376"><a href="http://ekartingnews.com/category/driver-diary/">EKN Driver Diary</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-910"><a href="http://ekartingnews.com/category/driver-rankings/">Driver Rankings</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55572"><a href="http://ekartingnews.com/category/industry-insider/">Industry Insider</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18814"><a href="http://ekartingnews.com/category/1on1/">EKN One-on-One</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38700"><a href="http://ekartingnews.com/category/ontrack/">EKN OnTrack</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20717"><a href="http://ekartingnews.com/category/grassroots/">Operation Grassroots</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59332"><a href="http://ekartingnews.com/category/product/">Product Spotlight</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41221"><a href="http://ekartingnews.com/category/road-racing/">Road Racing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66913"><a href="http://ekartingnews.com/category/vintage/">Vintage</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-911"><a href="http://ekartingnews.com/category/ekn-101/">EKN 101</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-902"><a href="http://ekartingnews.com/category/columns/">Columns</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13620"><a href="http://ekartingnews.com/category/columns/rob-howden/">Rob Howden</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13618"><a href="http://ekartingnews.com/category/columns/david-cole/">David Cole</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13619"><a href="http://ekartingnews.com/category/columns/guest-columns/">Guest Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13606"><a href="http://ekartingnews.com/category/columns/morning-coffee/">Morning Coffee</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25805"><a href="http://ekartingnews.com/category/columns/from-the-tower/">From the Tower</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-907"><a href="http://ekartingnews.com/forums">Forums</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4598"><a href="http://ekartingnews.com/forums">Forums</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-78098"><a href="http://ekartingnews.com/forums/forum/kart-mall/">EKN Kart Mall</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3501"><a href="http://ekartingnews.com/faq/">Forum Guidelines &#8211; FAQ</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10494"><a href="http://ekartingnews.com/forums/view/latest-topics/">New Topics</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14619"><a href="http://ekartingnews.com/forums/view/new-posts-last-visits/">New Posts Since Last Visit</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10319"><a href="http://ekartingnews.com/members">EKN Global Members</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4600"><a href="http://eknclassic.com/forum.php">EKN Classic Forum Archive</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33172"><a href="http://www.ekartingnews.com">Media</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80809"><a href="http://ekartingnews.com/podcast/">Podcast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33173"><a href="http://ekartingnews.com/category/video/">Video</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33174"><a href="https://www.youtube.com/user/ekartingnewsvideo/">EKN Youtube</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60594"><a href="http://ekartingnews.com/galleries/">Photo Galleries</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5469"><a href="http://www.ekartingnews.com/live">Live</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16096"><a href="http://styledaesthetic.com/ekartingnews/">e &#8211; SWAG</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36082"><a href="http://www.ekartingnews.com">Series/Events</a>
<ul  class="sub-menu">
	<li class="ekn-canada menu-item menu-item-type-custom menu-item-object-custom menu-item-3485"><a href="http://ekartingnews.com/category/canada/">EKN CANADA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45508"><a href="http://ekartingnews.com/category/briggs/">Briggs Racing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36072"><a href="http://ekartingnews.com/category/can-am/">Can-Am Karting Challenge</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36076"><a href="http://ekartingnews.com/category/challenge-of-the-americas/">Challenge Of The Americas</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36073"><a href="http://ekartingnews.com/category/florida-winter-tour/">Florida Winter Tour</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60676"><a href="http://ekartingnews.com/category/ikf/">International Kart Federation</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81282"><a href="http://ekartingnews.com/category/lakc/">Los Angeles Karting Championship</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36074"><a href="http://ekartingnews.com/category/rigp/">Rock Island Grand Prix</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-36075"><a href="http://ekartingnews.com/category/rok-cup-usa/">Rok Cup USA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79684"><a href="http://ekartingnews.com/category/route-66/">Route 66 Sprint Series</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36077"><a href="http://ekartingnews.com/category/superkarts-usa/">Superkarts! USA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36078"><a href="http://ekartingnews.com/category/texas-pkc/">Texas ProKart Challenge</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36079"><a href="http://ekartingnews.com/category/uspks/">United States Pro Kart Series</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36080"><a href="http://ekartingnews.com/category/usrmc/">United States Rotax Max Challenge</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40834"><a href="http://ekartingnews.com/category/world-karting-association/">World Karting Association</a></li>
</ul>
</li>
</ul></div></div></div>		</div>
		
		<!-- CLEAR -->
		<div class="clear"></div>
	</div>
<div id="footer"><!-- FOOTER -->
					<div id="footer_sidebar"><!-- FOOTER SIDEBAR -->
									<div class="footer_sidebar">
						<div class="footer_widget"><h2 class="heading">Latest EKN Forum Topics</h2>
		<ul>

			
				<li>
					<a class="bbp-forum-title" href="http://ekartingnews.com/forums/topic/yamaha-kt100-recoil-starter/">Yamaha KT100 Recoil Starter</a>

					
						by <span class="topic-author"><a href="http://ekartingnews.com/members/steve06k/" title="View Steve06k&#039;s profile" class="bbp-author-avatar" rel="nofollow"></a>&nbsp;<a href="http://ekartingnews.com/members/steve06k/" title="View Steve06k&#039;s profile" class="bbp-author-name" rel="nofollow">Steve06k</a></span>
					
					
						<div>6 hours, 18 minutes ago</div>

					
				</li>

			
				<li>
					<a class="bbp-forum-title" href="http://ekartingnews.com/forums/topic/rock-island-grand-prix-2017-discussion/">Rock Island Grand Prix 2017 Discussion</a>

					
						by <span class="topic-author"><a href="http://ekartingnews.com/members/david-cole/" title="View David Cole&#039;s profile" class="bbp-author-avatar" rel="nofollow"></a>&nbsp;<a href="http://ekartingnews.com/members/david-cole/" title="View David Cole&#039;s profile" class="bbp-author-name" rel="nofollow">David Cole</a></span>
					
					
						<div>6 hours, 21 minutes ago</div>

					
				</li>

			
				<li>
					<a class="bbp-forum-title" href="http://ekartingnews.com/forums/topic/where-are-the-hoovers/">Where are the Hoovers?</a>

					
						by <span class="topic-author"><a href="http://ekartingnews.com/members/billschmidt/" title="View Bill Schmidt&#039;s profile" class="bbp-author-avatar" rel="nofollow"></a>&nbsp;<a href="http://ekartingnews.com/members/billschmidt/" title="View Bill Schmidt&#039;s profile" class="bbp-author-name" rel="nofollow">Bill Schmidt</a></span>
					
					
						<div>15 hours, 59 minutes ago</div>

					
				</li>

			
				<li>
					<a class="bbp-forum-title" href="http://ekartingnews.com/forums/topic/2016-trutech-x30-jr-package-2200/">2016 TruTech X30 JR Package $2200</a>

					
						by <span class="topic-author"><a href="http://ekartingnews.com/members/jdmotorsports95/" title="View Phil Demars&#039;s profile" class="bbp-author-avatar" rel="nofollow"></a>&nbsp;<a href="http://ekartingnews.com/members/jdmotorsports95/" title="View Phil Demars&#039;s profile" class="bbp-author-name" rel="nofollow">Phil Demars</a></span>
					
					
						<div>17 hours, 23 minutes ago</div>

					
				</li>

			
				<li>
					<a class="bbp-forum-title" href="http://ekartingnews.com/forums/topic/l0206-masters-old-farts-like-myself-2/">L0206 Masters, Old farts like myself.</a>

					
						by <span class="topic-author"><a href="http://ekartingnews.com/members/fastfreddy/" title="View FREDDY SANDOVAL&#039;s profile" class="bbp-author-avatar" rel="nofollow"></a>&nbsp;<a href="http://ekartingnews.com/members/fastfreddy/" title="View FREDDY SANDOVAL&#039;s profile" class="bbp-author-name" rel="nofollow">FREDDY SANDOVAL</a></span>
					
					
						<div>18 hours, 10 minutes ago</div>

					
				</li>

			
		</ul>

		</div>					</div>
								
									<div class="footer_sidebar">
						<div class="footer_widget"><h2 class="heading">HOWDEN MEDIA GROUP</h2>			<div class="textwidget"><p><img src="http://ekartingnews.com/wp-content/uploads/2015/02/ekn-footer-logo.png"/>
      <ul>
          <li><a href="http://howdenmediagroup.com/">Publisher Info</a></li>
          <li>News Desk &amp; Content<br />
<em>- newsdesk@ekartingnews.com</em></li>
          <li>EKN For Your Business | Advertising<br />
<em>- sales@ekartingnews.com</em></li>
          <li>Insider Login Issues | Help | Feedback<br />
<em>- webmaster@ekartingnews.com</em></li>
        </ul>
</p>
        </div>
		</div>					</div>
								
									<div class="footer_sidebar">
						<div class="footer_widget"><h2 class="heading">EKN TRACKSIDE LIVE TOUR</h2>			<div class="textwidget"><p><a href="http://ekartingnews.com/wp-content/plugins/adrotate-pro/adrotate-out.php?track=MTIsMCwwLGh0dHA6Ly93d3cuZWthcnRpbmduZXdzLmNvbS9saXZl" target="_blank"><img src="http://ekartingnews.com/wp-content/uploads/2017/08/ekn-live-banner-RIGP-2017.gif" /></a></p>
<p>August 25-27, 2017<br />
Dousman, Wisconsin<br />
<em><a href="http://www.worldkarting.com" target="_blank" rel="noopener">WKA Manufacturers Cup Series</a></em></p>
<p>September 2-3, 2017<br />
Rock Island, Illinois<br />
<a href="http://rockislandgrandprix.com/" target="_blank" rel="noopener">Rock Island Grand Prix</a></p>
<p>September 22-24, 2017<br />
Joliet, Illinois<br />
<em><a href="http://www.uspks.com" target="_blank" rel="noopener">United States Pro Kart Series</a></em></p>
</div>
		</div>					</div>
								
				                        			<div class="footer_sidebar">
                        			<div class="footer_widget"><h2 class="heading">Take Part In The Discussion</h2><div class="menu-take-part-in-the-discussion-container"><ul id="menu-take-part-in-the-discussion" class="menu"><li id="menu-item-62046" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62046"><a href="http://ekartingnews.com/forums/forum/general-karting-discussion/">General Karting Discussion</a></li>
<li id="menu-item-62051" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62051"><a href="http://ekartingnews.com/forums/forum/chassis-handling/">Chassis &#038; Handling</a></li>
<li id="menu-item-62055" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62055"><a href="http://ekartingnews.com/forums/forum/shifter-karts/">Shifter Karts</a></li>
<li id="menu-item-62056" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62056"><a href="http://ekartingnews.com/forums/forum/tag/">TaG</a></li>
<li id="menu-item-62053" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62053"><a href="http://ekartingnews.com/forums/forum/tag/rotax-max/">Rotax Max</a></li>
<li id="menu-item-62052" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62052"><a href="http://ekartingnews.com/forums/forum/road-racing/">Road Racing</a></li>
<li id="menu-item-62047" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62047"><a href="http://ekartingnews.com/forums/forum/classifieds/">Classifieds</a></li>
</ul></div></div><div class="footer_widget"><h2 class="heading">Start Racing Now!</h2><div class="menu-start-racing-container"><ul id="menu-start-racing" class="menu"><li id="menu-item-62067" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62067"><a href="http://ekartingnews.com/forums/forum/classifieds/classifieds-kart-packages/">Classifieds &#8211; Kart Packages</a></li>
<li id="menu-item-62066" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62066"><a href="http://ekartingnews.com/forums/forum/classifieds/classifieds-chassis/">Classifieds &#8211; Chassis</a></li>
<li id="menu-item-62065" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62065"><a href="http://ekartingnews.com/forums/forum/classifieds/classifieds-engines/">Classifieds &#8211; Engines</a></li>
<li id="menu-item-62064" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62064"><a href="http://ekartingnews.com/forums/forum/classifieds/classifieds-parts/">Classifieds &#8211; Parts</a></li>
<li id="menu-item-62063" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62063"><a href="http://ekartingnews.com/forums/forum/classifieds/classifieds-misc/">Classifieds &#8211; Misc.</a></li>
<li id="menu-item-62068" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62068"><a href="http://ekartingnews.com/forums/forum/vintage-karting/">Vintage Karting</a></li>
<li id="menu-item-62070" class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-62070"><a href="http://ekartingnews.com/forums/forum/indoor-sport-karting/">Indoor / Sport Karting</a></li>
</ul></div></div>                    			</div>
                						
				<!-- CLEAR -->
				<div class="clear"></div>
			</div>
				
		<div id="credits">
			<div class="left">
				Copyright © 2002-2016 <a href="http://www.ekartingnews.com/"> eKarting News</a>. All Rights Reserved.			</div>
			
			<div class="right">
				 <a href="http://ekartingnews.com/privacy">Privacy Statement</a>   Site by Concepts In Concert</a>			</div>
			
			<div class="clear"></div>
		</div>
	</div>
</div>

<script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '582513206', '0');</script><script type='text/javascript' src='http://ekartingnews.com/wp-includes/js/comment-reply.min.js?ver=88b46b47daab60bfffad905c937b617b'></script>
<script type='text/javascript' src='http://ekartingnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://ekartingnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/gd-bbpress-toolbox/libs/fitvids/jquery.fitvids.js?ver=4.3.493'></script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/gd-bbpress-toolbox/js/render.min.js?ver=4.3.493'></script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/bbpress/templates/default/js/editor.js?ver=2.5.12-6148'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var BP_Confirm = {"are_you_sure":"Are you sure?"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/buddypress/bp-core/js/confirm.min.js?ver=2.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"http:\/\/ekartingnews.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"1","blog_home":"http:\/\/ekartingnews.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/cleantalk-spam-protect/inc/cleantalk_nocache.js?ver=5.73'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"338594701.3a81a9f.e85b596805e44135ab795fc8055443a1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.4.9'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201735'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var qpprFrontData = {"linkData":{"http:\/\/ekartingnews.com\/store\/":[1,0,""]},"siteURL":"http:\/\/ekartingnews.com","siteURLq":"http:\/\/ekartingnews.com"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.1.8'></script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/jetpack/modules/widgets/milestone/milestone.js?ver=20160520'></script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/jetpack/_inc/twitter-timeline.js?ver=4.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var shiftnav_data = {"shift_body":"on","shift_body_wrapper":"","lock_body":"on","lock_body_x":"off","swipe_close":"on","swipe_open":"off","swipe_tolerance_x":"150","swipe_tolerance_y":"60","swipe_edge_proximity":"80","open_current":"off","collapse_accordions":"off","scroll_panel":"on","breakpoint":"960","touch_off_close":"on","scroll_offset":"100","disable_transforms":"off"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/shiftnav-pro/assets/js/shiftnav.min.js?ver=1.4.0.1'></script>
<script type='text/javascript' src='http://ekartingnews.com/wp-includes/js/wp-embed.min.js?ver=88b46b47daab60bfffad905c937b617b'></script>
	<!-- ShiftNav Main Toggle -->
		<div id="shiftnav-toggle-main" class="shiftnav-toggle-main-align-center shiftnav-toggle-edge-left shiftnav-toggle-icon-bars shiftnav-toggle-main-align-center shiftnav-toggle-edge-left shiftnav-toggle-icon-bars" data-shiftnav-target="shiftnav-main"><span id="shiftnav-toggle-main-button" class="shiftnav-toggle shiftnav-toggle-shiftnav-main shiftnav-toggle-burger" data-shiftnav-target="shiftnav-main"><i class="fa fa-bars"></i></span>	<span class="shiftnav-main-toggle-content shiftnav-toggle-main-block">Karting's News and Information Leader 
    ekartingnews | an HMG publication </span></div>	
	<!-- /#shiftnav-toggle-main --> 


	<!-- ShiftNav #shiftnav-main -->
	<div class="shiftnav shiftnav-nojs shiftnav-shiftnav-main shiftnav-left-edge shiftnav-skin-slate shiftnav-transition-standard" id="shiftnav-main" data-shiftnav-id="shiftnav-main">
		<div class="shiftnav-inner">

		
			<div class="shiftnav-menu-image" id="shiftnav-menu-image-shiftnav-main">
		<a href="http://ekartingnews.com">							<img width="320" height="64" src="http://ekartingnews.com/wp-content/uploads/2016/02/eknNAVheader.png" class="attachment-full size-full" alt="" srcset="http://ekartingnews.com/wp-content/uploads/2016/02/eknNAVheader.png 320w, http://ekartingnews.com/wp-content/uploads/2016/02/eknNAVheader-300x60.png 300w" sizes="(max-width: 320px) 100vw, 320px" data-attachment-id="62083" data-permalink="http://ekartingnews.com/eknnavheader/" data-orig-file="http://ekartingnews.com/wp-content/uploads/2016/02/eknNAVheader.png" data-orig-size="320,64" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="eknNAVheader" data-image-description="" data-medium-file="http://ekartingnews.com/wp-content/uploads/2016/02/eknNAVheader-300x60.png" data-large-file="http://ekartingnews.com/wp-content/uploads/2016/02/eknNAVheader.png" />					</a>	</div>
	<nav class="shiftnav-nav"><ul id="menu-main-menu-2" class="shiftnav-menu shiftnav-targets-default shiftnav-targets-text-default shiftnav-targets-icon-default shiftnav-indent-subs shiftnav-active-on-hover"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-894 shiftnav-depth-0"><a class="shiftnav-target"  href="http://ekartingnews.com/">Home</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-896 shiftnav-sub-shift shiftnav-depth-0"><a class="shiftnav-target"  href="http://ekartingnews.com/news/">Headlines</a><span class="shiftnav-submenu-activation"><i class="fa fa-chevron-right"></i></span>
<ul class="sub-menu sub-menu-1">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-915 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/top-stories/">Top Stories</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-913 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-912 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/international/">International</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76462 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/newswire/">Newswire</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-914 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/pr-wire/">PR Wire</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5236 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/ekn-event-pages/">EKN Event Pages</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15254 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/paddock-insider/">Paddock Insider</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33136 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/canada/">Canada</a></li><li class="shiftnav-retract"><a class="shiftnav-target"><i class="fa fa-chevron-left"></i> Back</a></li></ul>
</li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-905 shiftnav-sub-shift shiftnav-depth-0"><a class="shiftnav-target"  href="http://ekartingnews.com/category/features/">Features</a><span class="shiftnav-submenu-activation"><i class="fa fa-chevron-right"></i></span>
<ul class="sub-menu sub-menu-1">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40870 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/chassis-showroom/">EKN Chassis Showroom</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-908 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/constructors-championship/">Constructors Championship</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-909 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/driver-of-the-month/">Driver Of The Month</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40376 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/driver-diary/">EKN Driver Diary</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-910 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/driver-rankings/">Driver Rankings</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55572 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/industry-insider/">Industry Insider</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18814 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/1on1/">EKN One-on-One</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38700 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/ontrack/">EKN OnTrack</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20717 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/grassroots/">Operation Grassroots</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59332 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/product/">Product Spotlight</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41221 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/road-racing/">Road Racing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66913 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/vintage/">Vintage</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-911 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/ekn-101/">EKN 101</a></li><li class="shiftnav-retract"><a class="shiftnav-target"><i class="fa fa-chevron-left"></i> Back</a></li></ul>
</li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-902 shiftnav-sub-shift shiftnav-depth-0"><a class="shiftnav-target"  href="http://ekartingnews.com/category/columns/">Columns</a><span class="shiftnav-submenu-activation"><i class="fa fa-chevron-right"></i></span>
<ul class="sub-menu sub-menu-1">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13620 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/columns/rob-howden/">Rob Howden</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13618 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/columns/david-cole/">David Cole</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13619 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/columns/guest-columns/">Guest Columns</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13606 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/columns/morning-coffee/">Morning Coffee</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25805 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/columns/from-the-tower/">From the Tower</a></li><li class="shiftnav-retract"><a class="shiftnav-target"><i class="fa fa-chevron-left"></i> Back</a></li></ul>
</li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-907 shiftnav-sub-shift shiftnav-depth-0"><a class="shiftnav-target"  href="http://ekartingnews.com/forums">Forums</a><span class="shiftnav-submenu-activation"><i class="fa fa-chevron-right"></i></span>
<ul class="sub-menu sub-menu-1">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4598 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/forums">Forums</a></li><li class="menu-item menu-item-type-post_type menu-item-object-forum menu-item-78098 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/forums/forum/kart-mall/">EKN Kart Mall</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3501 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/faq/">Forum Guidelines &#8211; FAQ</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10494 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/forums/view/latest-topics/">New Topics</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14619 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/forums/view/new-posts-last-visits/">New Posts Since Last Visit</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10319 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/members">EKN Global Members</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4600 shiftnav-depth-1"><a class="shiftnav-target"  href="http://eknclassic.com/forum.php">EKN Classic Forum Archive</a></li><li class="shiftnav-retract"><a class="shiftnav-target"><i class="fa fa-chevron-left"></i> Back</a></li></ul>
</li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33172 shiftnav-sub-shift shiftnav-depth-0"><a class="shiftnav-target"  href="http://www.ekartingnews.com">Media</a><span class="shiftnav-submenu-activation"><i class="fa fa-chevron-right"></i></span>
<ul class="sub-menu sub-menu-1">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80809 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/podcast/">Podcast</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33173 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/video/">Video</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33174 shiftnav-depth-1"><a class="shiftnav-target"  href="https://www.youtube.com/user/ekartingnewsvideo/">EKN Youtube</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60594 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/galleries/">Photo Galleries</a></li><li class="shiftnav-retract"><a class="shiftnav-target"><i class="fa fa-chevron-left"></i> Back</a></li></ul>
</li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5469 shiftnav-depth-0 shiftnav-has-icon"><a class="shiftnav-target"  href="http://www.ekartingnews.com/live"><i class="shiftnav-icon fa fa-microphone"></i><span class="shiftnav-target-text">Live</span></a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16096 shiftnav-depth-0"><a class="shiftnav-target"  href="http://styledaesthetic.com/ekartingnews/">e &#8211; SWAG</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36082 shiftnav-sub-shift shiftnav-depth-0"><a class="shiftnav-target"  href="http://www.ekartingnews.com">Series/Events</a><span class="shiftnav-submenu-activation"><i class="fa fa-chevron-right"></i></span>
<ul class="sub-menu sub-menu-1">
<li class="ekn-canada menu-item menu-item-type-custom menu-item-object-custom menu-item-3485 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/canada/">EKN CANADA</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45508 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/briggs/">Briggs Racing</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36072 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/can-am/">Can-Am Karting Challenge</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36076 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/challenge-of-the-americas/">Challenge Of The Americas</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36073 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/florida-winter-tour/">Florida Winter Tour</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60676 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/ikf/">International Kart Federation</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81282 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/lakc/">Los Angeles Karting Championship</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36074 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/rigp/">Rock Island Grand Prix</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-36075 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/rok-cup-usa/">Rok Cup USA</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79684 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/route-66/">Route 66 Sprint Series</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36077 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/superkarts-usa/">Superkarts! USA</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36078 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/texas-pkc/">Texas ProKart Challenge</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36079 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/uspks/">United States Pro Kart Series</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36080 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/usrmc/">United States Rotax Max Challenge</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40834 shiftnav-depth-1"><a class="shiftnav-target"  href="http://ekartingnews.com/category/world-karting-association/">World Karting Association</a></li><li class="shiftnav-retract"><a class="shiftnav-target"><i class="fa fa-chevron-left"></i> Back</a></li></ul>
</li></ul></nav>		</div><!-- /.shiftnav-inner -->
	</div><!-- /.shiftnav #shiftnav-main -->


	
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/ekartingnews.com\/2017\/08\/30\/rok-cup-promotions-sets-2018-rok-cup-usa-event-calendar\/":85364};
	</script>
		<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ekartingnews.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.2.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
</body>
</html>